What to do if you receive the following error "XML Parsing Error at 1:1. Error 4: Not well-formed (invalid token)" when installing a Joomla! module.

Explanation: The files in the module have been zipped using an Apple MAC. The MAC adds an extra folder called __MACOSX into the modules zip file.

Follow these steps in order to solve the problem.

STEP 1

Unzip (Extract) the modules zip file.

STEP 2

Open the unzipped (extracted) folder.

STEP 3

Delete the  __MACOSX folder within the unzipped (extracted) folder.

STEP 4

Zip the unzipped (extracted) folder (The extracted module) and re-install the module and the error message will disappear.

 

NOTE: The module will still be installed successfully whether the error message appears or not. 

I have the same issue here although I have latest joomla 1.5.14 and my templatedetails.xml has no params at all, please check my templatedetails.xml and my temple it mediamania from digimania www.dezinedepot.com/joomla/commercial-jo...ockettheme-digimania but I edited its CSS from a while, and my website is hosted on Microsoft Windows Server with xampp (apache friends)



md_digimania
1.0.5
05/31/05
rhuk
rhuk@rockettheme.com
www.rockettheme.com
Copyright 2005 - RocketTheme.com


DigiMania Overview Page on rockettheme.com.

Changelog
1.0.5

turned off notices in md_suckerfish.php

1.0.4

Fixed 2 undefined notices in md_suckerfish.php

1.0.3

Fixed a color box rendering issue in IE that was causing the boxes to bleed over the right margin

1.0.2

Fixed a problem with small bits of content not forcing the full width of the template


1.0.1

initial Release

]]>


css/blue_css.css
css/default_css.css
css/green_css.css
css/index.html
css/red_css.css
images/arrow.png
images/dm_box_bl_blue.png
images/dm_box_bl_green.png
images/dm_box_bl_red.png
images/dm_box_br_blue.png
images/dm_box_br_green.png
images/dm_box_br_red.png
images/dm_box_tl_blue.png
images/dm_box_tl_green.png
images/dm_box_tl_red.png
images/dm_box_tr_blue.png
images/dm_box_tr_green.png
images/dm_box_tr_red.png
images/dm_fade_bg.png
images/dm_header_bl_blue.png
images/dm_header_bl_green.png
images/dm_header_bl_red.png
images/dm_header_br_blue.png
images/dm_header_br_green.png
images/dm_header_br_red.png
images/dm_header_tl_blue.png
images/dm_header_tl_green.png
images/dm_header_tl_red.png
images/dm_header_tr_blue.png
images/dm_header_tr_green.png
images/dm_header_tr_red.png
images/dm_logo_blue.png
images/dm_logo_green.png
images/dm_logo_red.png
images/dm_menu_bg_blue.png
images/dm_menu_bg_green.png
images/dm_menu_bg_red.png
images/dm_menu_underline_blue.png
images/dm_menu_underline_green.png
images/dm_menu_underline_red.png
images/dm_tab_normal_l_blue.png
images/dm_tab_normal_l_green.png
images/dm_tab_normal_l_red.png
images/dm_tab_normal_r_blue.png
images/dm_tab_normal_r_green.png
images/dm_tab_normal_r_red.png
images/dm_tab_over_l_blue.png
images/dm_tab_over_l_green.png
images/dm_tab_over_l_red.png
images/dm_tab_over_r_blue.png
images/dm_tab_over_r_green.png
images/dm_tab_over_r_red.png
images/dm_underline.png
images/indent1.png
images/indent2.png
images/indent3.png
images/indent4.png
images/index.html
images/spacer.png
index.php
js/ie.js
js/index.html
md_suckerfish.php
templateDetails.xml
template_thumbnail.png



VOTES:1
Hi Mohamed,

What is the exact XML error that you get when trying to upload the template?

Also did you add any additional images to the images folder in the templates directory?

Everytime you add a new image to your images directory you need to add it in the templatedetails.xml file as well. Eg. images/new_image.png

This goes for everthing you add to your current templates directory.
VOTES:0
Thank you 1st,

well, my template is already there in my joomla and working I have no troubles with installing or uninstalling any components or modules, I only see whenever I want to add or uninstall extension the following error message:

XML Parsing Error at 1:1. Error 4: Not well-formed (invalid token)


VOTES:1
Is Legacy Support enabled?
VOTES:0
Yes and I did not have any problems before as my joomla is running 1 year ago, but I think this is an issue of Macintosh computers and this is weird to me as I sometimes edit or log on to joomla from my macbook but the joomla is hosted on windows and it was on IIS then to try to fix this issue I moved it to Apache also on Windows...!
VOTES:0
Just make sure that in the Zip File there isn\'t any __MACOSX folders. Then again if you get this error it still means that the extension has successfully installed.
VOTES:0
ok I\'ll do the needful and see what I have got but how to get this error message once I click on install without even choose the zip package I want to add!!!? I think it\'s because of previous components zipped on Mac, I\'ll try to uninstall the components and install it again, i\'ll feed you back
VOTES:0
The Feedback will be appreciated
VOTES:1
Hello.
i make a template in pc machine. I get a same message in (XML Parsing Error at 1:1. Error 4: Not well-formed (invalid token))
The files in Mac OS machine to include in zip file with _ (underscore). xml its not found to pc zip file version.
Please help....
Thanks
VOTES:0
I think there could be an error with the xml file. Check for spelling mistakes etc. Compare the xml file with a xml file from a template that installed correctly. Also check that you included everything that needs to be in the xml file.
VOTES:0
hi I have problem
my template is ja portfolio. every thing was good and it works for 2 month. yesterday I gave this error in frontpage:
XML Parsing Error at 1:2635. Error 4: not well-formed (invalid token)
can anyone help me?

VOTES:0
Did you install any additional modules, plugins or components after your 2month period?
VOTES:0
you can find solution for this question here and also download invalid character remover here:-
professionals-helpdesk.blogspot.com/2011...-unicode-0x-was.html
VOTES:0
! Check your XML file with wrong characters. This error cause by wrong characters found in the XML file. Hope that helps
VOTES:0